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1 Qualisist Add-Ins Installation

The Qualisist add-ins provide tool support to the Qualisist methodology. In partic-
ular, Add-Ins provide a means of extending Enterprise Architect1, by adding new
menus, sub-menus, windows, toolboxes, and other controls to perform a variety of
functions.

The first Add-In is named “Qualisist Requirements Editing Tools” which in-
cludes:

• A requirements editor;

• A tool to configure auto naming for functional requirements;

• A tool to manage relationships via trace links between the elements in Ac-
tivity Diagrams and requirements.

The second Add-In is named “Qualisist Acceptance Criteria (AC) Generator”
which includes:

• A tool to generate system-level acceptance criteria;

1https://www.sparxsystems.com/
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• An extension and customization of the modeling functionality of Enterprise
Architect to model systems following the Qualisist methodology

The third Add-In is named “Qualisist Model Validation” which includes a set
of rules to validate the elements on the model and check their consistency.

The last Add-In is named “ Qualisist Report Generator” that allows the user to
generate from the model, a full deliverable document. The document follows the
style and structure proposed by Clearstream IFS which is aligned with industry
standards.

This section explains how to install the Qualisist Add-Ins on your computer.

1. jre-8u171-windows-i586.exe

2. apache-tomcat-9.0.20.exe

3. Qualisist RE Tools.msi

4. Qualisist AC Generator.msi

5. Qualisist Model Validation.msi

6. Qualisist Report Generator.msi

The following subsections will explain how and in which order the above files
will be used.

1.1 Prerequisites

Java SE and Apache Tomcat version will need to be installed on your computer
before installing “Qualisist RE Tools”.

1.1.1 Installation of Java

Check if Java SE 8 is installed on your computer. Otherwise, install Java SE 8
using the file jre-8u171-windows-i586.exe.

You can follow the following step to check if Java SE is installed in your com-
puter:

1. Select Start→ Control Panel→ Programs and Features. You will see the
list of installed software on your computer. The list is sorted alphabetically.

2. If Java is installed in your computer, you will see the Java name on the list.
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1.1.2 Installation and Configuration of Apache Tomcat

Apache Tomcat is a web server which provides the features described in Section 4.3.
To install Apache Tomcat, double click on apache-tomcat-9.0.20.exe. The window
in Figure 1 will appear.

Figure 1: Welcome page of the Apache Tomcat setup.

Click on “Next” then check the options as shown in Figure 2.

Figure 2: Choose the features of Apache Tomcat to install.

Click on “Next” and configure the ports numbers as shown in Figure 3. Set a
personal user name and password.
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Figure 3: Configure Apache Tomcat.

Clicking on “Next”, the installer asks the user to select the path where Java
SE is installed. The default path is C: \Program Files \Java. Include in the path
the JRE folder as for example in Figure 4.

Figure 4: Select the path where Java SE is installed.

Once the path is set, click on “Next”. The installer asks the user the location
where to install the Tomcat service. Click “Next”. Once the install is complete,
click “Next”.
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Open the Menu Start of Windows and search “Configure Tomcat”. Open the
tool and set the “Startup type” to “Automatic” as shown in Figure 5, then click
on “Apply”.

Figure 5: Configuring Apache Tomcat.

1.2 Qualisist Requirement Editing Tools Installation

To install the Add-In, double click on Qualisist RE Tools.msi. Click “Next” on
the first page of the wizard shown in Figure 6.
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Figure 6: “Qualisist Requirement Editing Tools” Setup Wizard.

Next, choose the location where you want to install the Add-In. Click “Next”.

Figure 7: The wizard asks the user to select the installation folder.

Once the install is complete, click “Close”.
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Figure 8: Qualisist Requirements Editing Tools has been successfully installed on
your computer

1.3 Qualisist Acceptance Criteria Generator Installation

To install the Add-In, double click on Qualisist AC Generator.msi. The first page
of the Setup Wizard will appear as shown in Figure 9. Go ahead and click “Next”
on the first page.

Figure 9: The “Qualisist AC Generator” setup wizard.
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Next, you will choose the location where you want to install the Qualisist
Acceptance Criteria Generator as shown in Figure 10. Click “Next”.

Figure 10: The installer asks the user to select the installation folder.

Once the install is complete, click “Close”.

Figure 11: Qualisist AC Generator is installed on your computer.
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1.4 Qualisist Model Validation Installation

To install the Add-In, double click on Qualisist Model Validation.msi. The first
page of the Setup Wizard will appear as shown in Figure 12. Go ahead and click
“Next” on the first page.

Figure 12: “Qualisist Validation Rules” Setup Wizard.

Next, you will choose the location where you want to install the Qualisist
Validation Rules as shown in Figure 13. Click “Next”.

Figure 13: The installer asks the user to select the installation folder.
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Once the install is complete, click “Close”.

Figure 14: Qualisist Validation Rules is installed on your computer.

1.5 Qualisist Report Generator Installation

To install the Add-In, double click on Qualisist Report Generator.msi. The first
page of the Setup Wizard will appear as shown in Figure 15. Go ahead and click
“Next” on the first page.

Figure 15: “Qualisist Report Generator” Setup Wizard.
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Next, you will choose the location where you want to install the Qualisist
Report Generator as shown in Figure 13. Click “Next”.

Figure 16: The installer asks the user to select the installation folder.

Once the install is complete, click “Close”.

Figure 17: Qualisist Report Generator is installed on your computer.
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2 SRA Modelling

Qualisist MDG Technology includes a wide range of facilities and tools, such as
UML Profiles, stereotypes, patterns, tagged value types, attribute types and tool-
box pages and model template. Thanks to these features, the user is able to cre-
ate and insert information in an Enterprise Architect’s model which respects the
methodology proposed by Clearstream. From this model, it will then be possible
to generate a Word document that includes the information entered in Enterprise
Architect.

To activate Qualisist MDG Technology, from the top bar menu click on Specialize→
Technologies→Manage. The dialog list in Figure 18 will appear. Tick the item
“Qualisist modeling” and click on “Ok”.

Figure 18: List of all the MDG Technologies available in Enterprise Architect

2.1 How create a SRA model using the Model Wizard

The Model Wizard view provides patterns from a wide range of technologies,
which you can use to quickly generate new models in your project both when you
first create the project and over time. Qualisist provides a model pattern named
“Qualisist SRA Model” structured following the structure of an SRA document.
The Model Wizard automatically displays when creating a new project, otherwise
use these options to access it:

• From the top bar menu, Design → Package → Insert →
Insert using Model Wizard

• Right-click on the root package, then from the menu item click on “Add a
Model using Wizard”

• Click on the root package, then press the key combination Ctrl+Shift+M
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The view in Figure 19 will appear. You can choose two different model from the
“Perspective” box:

• “Qualisist: SRA Model”: a model that already includes the SRA structure
and some diagrams, functional requirements etc.

• “Qualisist: SRA Empty Model”: a model that includes only the SRA struc-
ture, without any element.

Once you have chosen the model, click on “Create Pattern(s)”.

Figure 19: Model Wizard in Enterprise Architect

The packages structure in Figure 20 will be generated.
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Figure 20: The model created using the Model Wizard

To allow the correct generation of a full deliverable document from the model,
we need to set the stereotype for those packages that we want to document. First
of all, create a new package and from the “Element Properties” box open the drop-
down menu next to the Stereotype item and select “browse other stereotypes...”.
The form in Figure 21 will appear.
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Figure 21: Form to set Qualisist stereotype for a package

Select Qualisist from the list of the profiles and then the value according to the
section that you are going to model. In each package you can create the appropriate
elements. For example, in the “Main Contacts” package, only the contacts element
can be created. For example if you try to create a contact element in the package
“History”, an error message will be displayed.

In the next sections, will be explained how to create a model from scratch.

2.2 List View and Specification Manager

List View and Specification Manager are two ways for viewing the contents of
a package in Enterprise Architect. In particular, we use List View to show the
content of the packages containing the following SRA elements:

• History

• Main Contacts

• Scope Definition

• Key Principles, Decisions, Assumptions and Constraints

• Data Dictionary

• Data Mapping

There are two ways to view the content of a package using List View:
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• Right-click on the package then from the menu Open Package in→ List V iew

• After selecting the package press Ctrl+Alt+R

Then you can add a new SRA element in a package in four ways:

1. Select a package in Project Browser, then from the menu item click on “Add
Element”

2. Select a package, then from the top bar menu, Design → Element →
Insert→ Insert New Element into Model...

3. After selecting a package where you want to add the new element, press the
key combination Ctrl+N

4. After opening a package in List View mode, right-click on a blank space and
then from the menu item select “Add New Element”

The dialog box in Figure 22 will appear. Click on the button “Toolset” to select
the toolset according to the element type that you want to create. After that,
click on “Type” to select the type of element. Finally, type the name of the new
element and click on “Save and Exit”.

Figure 22: Dialog window to create a new element

The new element will be saved in the package previously selected. According
to the type of the elements shown, you can load the columns layout to show the
information related to those elements. To do it, right-click on a blank space and
then from the menu item select Columns Layout → Load Columns Layout as
shown in Figure 23.
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Figure 23: Menu item to load columns layout

The form in Figure 24 will appear. Select the appropriate layout from the list.

Figure 24: Form to load column layout

We use Specification Manager to show the package containing the requirements.
There are two ways to view the content of a package using the Specification Man-
ager:

• Right-click on the package then from the menu Open Package in→ Specification Manager

• After selecting the package press Ctrl+0

To add a new functional requirement, use the methods 1 or 2 previously described
otherwise the auto-naming function described in chapter 6 will not work.

2.3 Qualisist View

Qualisist View is a tool to view and manage the Qualisist elements in a simple
way from the user perspective.

The tool can be opened in the followings ways:

• In the Project Browser, select a package that contains Qualisist elements and
then from the Top Bar Menu select
Specialize→ Qualisist RE Tools→ Qualisist V iew

19
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• In the Project Browser, select a package that contains Qualisist elements.
Then right-click on Specialize→ Qualisist RE Tools→ Qualisist V iew

For example, in Figure 25, the tool is displaying all the contacts contained in
the package “Main Contacts”. Each column is an element property that you can
edit.

Figure 25: Qualisist View is displaying the contacts

You can create or remove an element in the package by clicking on the proper
button on top of the table. To remove an element, select the row as shown in
Figure 26 then click on the button “Remove”.

Figure 26: Remove element in Qualisist View

2.4 Define the format of data attribute

According to the Clearstream methodology, Qualisist provides four data formats:

• Boolean: a data attribute, which will contain the value either true or false

• Date: a data attribute, which will contain a timestamp

• Alphanumeric: a data attribute, which will contain either of numbers and/or
alphabetical characters

• Numeric: a data attribute which will contain only numbers (either integers
or decimals)

To enter one of these data formats, select the element where the attributes will be
defined. Open the “Element Properties” window by using:

• Top bar menu: Start→ Explore→ Properties→ Properties

• Shortcut: Alt+1

Expand the section “Advanced” and select the item “Qualisist” from the language
list. To create and manage the attributes of an element, select the element. Then
open the “Features” window in the following ways:

20
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• Top bar menu: Design→ Element→ Features→ Attributes

• Right-click in Project Browser or diagram then from the menu item Features→
Attributes

• Shortcut: F9

The “Features” window presents a tab displaying the attributes that you create in
an element. To define the format of an attribute, select one of the items from the
list in the column “Type” as shown in Figure 27.

Figure 27: Formats of attributes available in Qualisist

2.5 History

This section describes how to model the History chapter of the SRA document
in Enterprise Architect. Create a package and set its stereotype to “History” 2.1.
To create a History element, open the dialog box “New Element” shown in Figure
22. From the toolsets, select Qualisist modeling → Qualisist History toolbox.
Type a name and click on “Save and Exit”. You can also use Qualisist View to
create and manage an history element in the package.2.3 A History element has
the following properties:

• Version

• Release Date

• Description

• Created / Amended by

• Reviewed by

• Comments Log

• Signed off by

• Sign-off Records

The Description property can be edit using the “Element Notes” box of Enter-
prise Architect. The other properties can be edit in the section “Qualisist” from
“Element Properties” box of Enterprise Architect.
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2.6 Main Contacts

This section describes how to model the Main Contacts chapter of the SRA doc-
ument in Enterprise Architect. Create a package and set its stereotype to “Main
Contacts” 2.1. A Contact element has the following properties:

• Contact Name

• Organization Area/Unit

• Role

To create a Contact element, open the dialog box “New Element”. From the
toolsets, select Qualisist modeling → Qualisist Main Contacts toolbox. Type
the name of the element which will be the Contact Name and click on “Save and
Exit”. The other properties can be edited in the section “Qualisist” from “Element
Properties” box of Enterprise Architect. You can also use Qualisist View to create
and manage a new contact element in the package.2.3

2.7 Summary and Business Context, Goals & Objectives

These chapters can be included in the project by using the Linked Documents.
First of all, create the respective two packages. Select, for example, the package
“Summary”, then open the ”Element Notes” box and click on the icon shown in
Figure 28.

Figure 28: Button to create a new Linked Document

The dialog box in Figure 29 will appear. Select “None” from the list of tem-
plates and click on “Ok”.
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Figure 29: New Linked Document from Template

An empty document will appear. You can add text, images, tables, etc., to the
document.

It is possible to import a previously created Word document into Enterprise
Architect: from the top bar menu Document→ Edit, select File→ Import F ile
as shown in Figure .

Figure 30: Menu item to import a file in Enterprise Architect

A window to select the Word document will appear. Select “MS Word Docu-
ment Format (*.DOCX)” as shown in Figure .

Figure 31: Window to import a Word document in Enterprise Architect
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Once the desired document has been selected, click on “Ok”.

Please note that Enterprise Architect doesn’t provide a tool to insert the cap-
tions. Use “Insert Caption” in Microsoft Word to insert them, otherwise, the
numbering of the figures in the document generated by Qualisist Report Genera-
tor will not be correct.

Figure 32: Button in top bar menu to insert elements such as figures in the linked
document

Once finished, you can export the document as a Microsoft Word file to include
it in the report generated by Qualisist Report Generator. From the top bar menu,
click on Document → Edit → File → Save as (Export to F ile) as shown in
Figure 33.

Figure 33: Button to export the linked document

Browse the file system where you want to save the file. Type the name, select
the type “.docx” in the list “Save as type” and click on “Save”.

Figure 34: Form to save the linked document as Word file
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2.8 Refined Project Scope

This section describes how to model the Refined Project Scope chapter of the SRA
document in Enterprise Architect. Qualisist provides to the user the packages
structure in Figure 35.

Figure 35: Structure of the package “Refined Project Scope”

Each sub-package contains the appropriate SRA elements. The following sub-
sections explain how to create the SRA elements in these sub-packages.

2.8.1 Scope Definition

This section describes how to model the following elements in Enterprise Architect:

• Foreword

• In Scope

• Out of Scope

To model the Foreword section, set the sub-package stereotype to the value “Fore-
word” as explained in section 2.1. Then, you can create a linked document 2.7 or
write text in the “Element Notes” box. The elements Out of Scope and In Scope
have the following properties:

• ID

• Area

• Description

• Rationale

To create one of these elements, open the dialog box “New Element”. From the
toolsets, select Qualisist modeling → Qualisist Scope Definition toolbox. From
the type list, select one of the entry according to the type of element that you
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want to create. Enter the name of the element which will be the Area in case
you are creating an In Scope or Out of Scope element and click on “Save and
Exit”. The ID value can be edit using the Alias property in the section “Element”
from “Element Properties” box of Enterprise Architect. The Rationale can be edit
in the section “Qualisist” from “Element Properties” box of Enterprise Architect.
The Description property can be edit using the “Element Notes” box of Enterprise
Architect.

2.8.2 Key Principles, Decisions, Assumptions and Constraints

This section describes how to model the following elements in Enterprise Architect:

• Key Decisions

• Key Principles

• Assumptions

• Constraints and Dependencies

Each element has the following properties:

• ID

• Area

• Description

• Rationale

To create one of these elements, open the dialog box “New Element”. From the
toolsets, select Qualisist modeling → Qualisist Key toolbox. From the type list,
select one of the entry according to the type of element that you want to create.
Enter the element name that will be the Area property and click on “Save and
Exit”. The ID value can be edit using the Alias property in the section “Element”
from “Element Properties” box of Enterprise Architect. The Rationale can be edit
in the section “Qualisist” from “Element Properties” box of Enterprise Architect.
The Description property can be edit using the “Element Notes” box of Enterprise
Architect.

2.9 Current and Future Overview

This section describes how to model the Current and Future Overview chapter
of the SRA document in Enterprise Architect. Create a new package and set its
stereotype 2.1 to the value “Current-Future” and click on “Ok”. Opening the
“Element Notes” of the package you can write the text that will be reported on
the document generated by Qualisist Report Generator.

The next step is to model in Enterprise Architect the sub-sections: Current
Situation, Future Situation and Functional Decomposition. Create three new sub-
packages, following as an example the structure shown in Figure 36.
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Figure 36: Structure of the package “Current and Future Overview”

The following sub-sections explain how to create the elements in these sub-
packages.

2.9.1 Current Situation “As-Is”

Regarding the current situation “As Is”, set the sub-package stereotype to the
value “As-Is” following the same procedure explained in section 2.1. Opening the
“Element Notes” of the sub-package you can write the text that will be reported on
the document generated by Qualisist Report Generator. You can add a diagram
to illustrate the current situation. The image of the diagram will be reported on
the document generated by Qualisist Report Generator. Once you have finished
modeling the diagram, you can edit its notes by using the “Diagram Notes” of
Enterprise Architect. The notes will be reported as a caption to the diagram
image on the document generated by Qualisist Report Generator.

2.9.2 Future Situation “To-Be”

Regarding the future situation “To Be”, set the sub-package stereotype to the
value ”To-Be” following the same procedure explained in section 2.1. Opening the
“Element Notes” of the sub-package you can write the text that will be reported on
the document generated by Qualisist Report Generator. You can add a diagram
to illustrate the future situation. The image of the diagram will be reported on
the document generated by Qualisist Report Generator. Once you have finished
modeling the diagram, you can edit its notes by using the “Diagram Notes” of
Enterprise Architect. The notes will be reported as a caption to the diagram
image on the document generated by Qualisist Report Generator.

2.9.3 Functional decomposition

The functional decomposition should be used to as the structure for the Func-
tional Requirements section 2.11, by functional domain, to better guide the reader
through the system changes described.

Create a sub-package inside the “Current and Future Overview” package as
shown in Figure36. By opening the “Element Notes” box you can enter the text
that will be shown in the model report. Each functional domain will be modeled
in Enterprise architect by creating sub-packages that will contain the diagrams.
The names of the sub-packages, corresponding to the functional domains, will be
the names of the subsections in the report. The image of the diagram will be
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reported on the document generated by Qualisist Report Generator. Once you
have finished modeling the diagram, you can edit its notes by using the “Diagram
Notes” of Enterprise Architect. The notes will be reported as a caption to the
diagram image on the document generated by Qualisist Report Generator.

2.10 Data Analysis

This section describes how to model the Data Analysis chapter of the SRA docu-
ment in Enterprise Architect. Qualisist provides to the user the packages structure
in Figure 37.

Figure 37: Structure of the package “Data Analysis”

Each sub-package contains the appropriate SRA elements. The following sub-
sections explain how to create the SRA elements in these sub-packages.

2.10.1 Conceptual Data Model

Create a sub-package inside the “Data Analysis” package as shown in Figure37 and
set its stereotype to Conceptual Data Model as explained in 2.1. By opening the
“Element Notes” box of the package you can enter the text that will be shown in
the model report. Finally, you can create a diagram inside the package to document
this model. The image of the diagram will be reported on the document generated
by Qualisist Report Generator. Once you have finished modeling the diagram, you
can edit its notes by using the “Diagram Notes” of Enterprise Architect. The notes
will be reported as a caption to the diagram image on the document generated by
Qualisist Report Generator.

2.10.2 Logical Model

First of all, create a package and set its stereotype to Logical Model as explained
in 2.1. You can edit the notes of the package by using the “Element Notes”
of Enterprise Architect. The notes will be reported on the report generated by
Qualisist Report Generator.

Also, you can add diagrams to illustrate the logical model. The image of
the diagrams will be reported on the document generated by Qualisist Report
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Generator. Once you have finished modeling the diagrams, you can edit their notes
by using the “Diagram Notes” of Enterprise Architect. The notes will be reported
as a caption to the diagrams image on the document generated by Qualisist Report
Generator. The image of the diagram will be reported on the document generated
by Qualisist Report Generator.

2.10.3 Data Dictionary

A Data Dictionary element has the following properties:

• Entity

• Field Name

• Description

• Type

• Domain value

• Mandatory / Optional

To create a Data Dictionary element, open the dialog box “New Element”. From
the toolsets, select Qualisist modeling → Qualisist Data Dictionary toolbox.
Type the name of the element which will be the Field Name and click on “Save
and Exit”. The Description property can be edit using the “Element Notes” box
of Enterprise Architect. The other properties can be edit in the section “Qualisist”
from “Element Properties” box of Enterprise Architect. In this section there are
also the fields:

• Length: edit this field to define the length of an Alphanumeric element type;
You can leave the default value in case you don’t know the length of the
field.

• Digits after and before comma: edit these fields to define the digits after and
before comma of a Number element type

2.10.4 Data Mapping

To model a data mapping element, create a package and set its stereotype to
Data Mapping Table. The name of the package will be reported on the docu-
ment generated by Qualisist Report Generator. Now you can add Data Mapping
elements to this package. A Data Mapping element has the following properties:

• General Term

• Field Source

• Field Target

• Source
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• Target

To create a Data Mapping element, open the dialog box “New Element”. From the
toolsets, select Qualisist modeling → Qualisist Data Mapping toolbox. Type
the name of the element which will be the General Term and click on “Save and
Exit”. To edit the properties of the element, double-click on it from the Project
Browser. Click on “Yes” on the dialog box. A form will be displayed. The
properties Field Source and Field Target are obtained from the values entered in
the class and property fields of the respective boxes. The label fields correspond
to the source and target properties in the respective boxes. Once finished click on
“Apply”.

2.11 Functional Requirements

This section describes how to model Functional Requirements chapter of the SRA
document in Enterprise Architect. First of all, create a new package and from
the “Element Properties” box set its stereotype to “Functional Requirements” as
explained in section 2.1. Opening the “Element Notes” of the package you can
write the text that will be reported on the document generated by Qualisist Report
Generator. The next is to model the functional domains. Create a sub-package of
the package just created, which will be the first functional domain. You can create
a structure as shown in Figure 38 to model a functional domain.

To explain the functional domain, you can write notes in the “Element Notes”
box of the sub-packages. The names and the notes of sub-packages will be reported
on the document generated by Qualisist Report Generator.

Also, you can add diagrams to illustrate the functional domain. The image
of the diagrams will be reported on the document generated by Qualisist Report
Generator. Once you have finished modeling the diagrams, you can edit their notes
by using the “Diagram Notes” of Enterprise Architect. The notes will be reported
as a caption to the diagrams image on the document generated by Qualisist Report
Generator.

Figure 38: Structure of the package “Functional Requirements”

2.11.1 Requirements Table

Following the structure proposed in Figure 38, you can add a sub-package to
contain functional requirements.
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To do it, create the sub-package and set its stereotype to “Requirements Ta-
ble” as explained in section 2.1. You can add notes to this package in the “El-
ement Notes” box. The name and the note of the package will be reported on
the document generated by Qualisist Report Generator. Now you can add the
functional requirements to this package. Open the dialog box “New Element”
following the methods 1 or 2. From the toolsets, select Qualisist modeling →
Qualisist Requirement toolbox and from “Type” list, select “Functional” and
type a name for the requirement. Then click on “Save and Exit” button. You can
edit the functional requirement element as described in section 4.

2.12 Transition Requirements

This section describes how to model the Transition chapter of the SRA document
in Enterprise Architect. A transition requirement has the following properties:

• Requirements ID: Unique identifier that consists of three letters and three
sequential numbers.

• Notes: Description of the requirement.

• Rationale: Explains why the requirement exists.

Create a new package to contain the transition requirements. Then, open the
dialog box “New Element” following the methods 1 or 2. From the toolsets, select
Qualisist modeling → Qualisist Requirement toolbox and from “Type” list,
select “Transition” and type a name for the requirement. Then click on “Save and
Exit” button. To edit the properties, open the package using the Specification
Manager as explained in 2.2.

2.13 Non-Functional Requirements

This section describes how to model the Non-Functional Requirements chapter of
the SRA document in Enterprise Architect. Qualisist provides to the user the
packages structure in Figure 35.
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Figure 39: Structure of the package “Non-Functional Requirements”

Each sub-package contains the appropriate non-functional requirement ele-
ments. To edit the properties, open the package using the Specification Manager
as explained in 2.2. In general a non-functional requirement has the following
properties:

• Requirements ID: Unique identifier that consists of three letters and three
sequential numbers.

• Notes: Description of the requirement.

• Rationale: Explains why the requirement exists.

The following sub-sections explain how to create the SRA elements in these sub-
packages.

2.13.1 Operational Requirements

Create a new package to contain the operational requirements following the struc-
ture shown in Figure 39. Then, open the dialog box “New Element” following the
methods 1 or 2. From the toolsets, select Qualisist modeling → Qualisist Requirement toolbox
and from “Type” list, select “Operational” and type a name for the requirement.
Then click on “Save and Exit” button.

2.13.2 Product Requirements

Create a new package to contain the operational requirements following the struc-
ture shown in Figure 39. Then, open the dialog box “New Element” following the
methods 1 or 2. From the toolsets, select Qualisist modeling → Qualisist Requirement toolbox
and from “Type” list, select “Operational” and type a name for the requirement.
Then click on “Save and Exit” button.
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2.13.3 Usability Requirements

Create a new package to contain the usability requirements following the structure
shown in Figure 39. Then, open the dialog box “New Element” following the meth-
ods 1 or 2. From the toolsets, select Qualisist modeling → Qualisist Requirement toolbox
and from “Type” list, select “Usability” and type a name for the requirement.
Then click on “Save and Exit” button.

2.13.4 Availability Requirements

Create a new package to contain the availability requirements following the struc-
ture shown in Figure 39. Then, open the dialog box “New Element” following the
methods 1 or 2. From the toolsets, select Qualisist modeling → Qualisist Requirement toolbox
and from “Type” list, select “Availability” and type a name for the requirement.
Then click on “Save and Exit” button.

2.13.5 Performance Requirements

Create a new package to contain the operational requirements following the struc-
ture shown in Figure 39. Then, open the dialog box “New Element” following the
methods 1 or 2. From the toolsets, select Qualisist modeling → Qualisist Requirement toolbox
and from “Type” list, select “Performance” and type a name for the requirement.
Then click on “Save and Exit” button.

2.13.6 Space Requirements

Create a new package to contain the space requirements following the structure
shown in Figure 39. Then, open the dialog box “New Element” following the meth-
ods 1 or 2. From the toolsets, select Qualisist modeling → Qualisist Requirement toolbox
and from “Type” list, select “Space” and type a name for the requirement. Then
click on “Save and Exit” button.

2.13.7 Security Requirements

Create a new package to contain the security requirements following the structure
shown in Figure 39 and set its stereotype to “Security Requirement Table” as
explained in section 2.1. To model the Security Requirements section, create
a linked document for the package as explained in 2.7. In this document, you
can insert the table to document the security requirements. Enterprise Architect
provides a tool to insert a table in the document. From the top bar menu, select
Document→ Edit→ Table→ Insert Table as shown in Figure 40.

Figure 40: Button to insert a table in a linked document.
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2.14 General Information

2.14.1 Related Documentation

2.15 Appendixes

3 Report Generation

Qualisist Report Generator is a tool that allows the user to generate a report from
a system modelled following Qualisist methodology in Enterprise Architect. The
generated document is a Word file which contains all the elements modelled in the
system.

3.1 How to run Qualisist Report Generator?

From the top bar menu, click on Specialize → Qualisist Report Generator →
Generate Report as shown in Figure 41.

Figure 41: How to run Qualisist Report Generator from the top bar menu of
Enterprise Architect

The form in Figure 43 will appear.
Once all the fields have been completed as described in Section 3.2, click on

“Apply” to generate the document.
When the progress bar is completely green as shown in 42, the document is

ready.

Figure 42: The document is ready to be opened

3.2 Defining properties of the report

In the form in Figure 43, you can enter the values of the following fields:

• Author of the document

• Category

• Subject

• Title of the document

• Document ID
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Figure 43: Defining the properties of the report

In the final document, you can insert the chapters regarding the “Summary”,
“Business Context, Goals & Objectives”, “Foreword”, “Related Documentation”
and “Appendixes”. To do it, click on the corresponding buttons indicated in Figure
44.

Figure 44: Clicking on the buttons, you can choose the Word documents to import

The form in Figure 45 will appear. Browse the file system where you saved the
corresponding file and after selecting it, click on “Open”.
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Figure 45: Form to import the chapter “Summary” in the document

Please note that if you don’t select a Word document for one of those chapters,
the notes of the related package will be included in the report.

The last value is the path of the output file. Click on the button shown in
Figure 46.

Figure 46: Clicking on the button, you can choose the path where to save the
document

The form in Figure 48 will appear. Browse the file system choosing the path
where you want to save the document, then type the name of the file and click on
“Save”.

Figure 47: The form where you can type the name of the final document and
where save it
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3.3 Options

Qualisist Report Generator provides to the user three options:

• Apply Colours to the Requirements Text: check this option if you want the
tool to apply the same colouring to the requirements descriptions as in the
Qualisist Editor

• Replace Dot Notation

• View Document on Completion: check this option to open automatically the
document at the end of generation process

Figure 48: Options provided by Qualisist Report Generation

4 Requirements Editing

4.1 What is Qualisist Requirement Editor?

Qualisist Requirement Editor is a tool that allows the user to edit and save the
properties following properties of a Functional Requirement:

• Requirements ID: Unique identifier that consists of three letters and three
sequential numbers.

• Notes: Description of the requirement.

• Rationale: Explains why the requirement exists.

• Examples: Illustrates the requirement.

Figure 49: Requirement editor.
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4.2 How to open the Qualisist Requirement Editor?

The requirements editor can be opened in three ways:

• Select the requirement in the Specification Manager view and then from the
Top Bar Menu select
Specialize → Qualisist RE Tools → Edit Requirement as shown in Fig-
ure 50

• Select the requirement in the Project Browser and then from the Top Bar
Menu select Specialize→ Qualisist RE Tools→ Edit Requirement

• Select the requirement in the Project Browser and then double click.

• Select an action related to at least one requirement through a trace link
from an activity diagram, from the Top Bar Menu select Specialize →
Qualisist RE Tools → Edit Requirement. You can also double click on
the action,

Figure 50: Top bar menu of Enterprise Architect.

4.3 Features of the Editor

The grammar implemented in Qualisist Requirement Editor provides useful func-
tions to assist the user in writing a well-formed requirement such as:

• Error checking: the editor automatically checks for errors, as shown in Fig-
ure 51.

Figure 51: Error checking.

• Content assist: the editor automatically provides content assist and auto-
completion through the key combination Ctrl + Space, as shown in Fig-
ure52.

• Syntax highlighting: keywords are highlighted, as shown in Figure51 and 52.
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Figure 52: Auto completion and content assist.

4.4 Other Capabilities

The editor gathers all the actors and classes from the model such as the user can
reference these entities to write a well-formed requirement. In case the user wants
to write a requirement, referencing a class or an actor that is not in the model, he
can create that reference in the editor:

• A new actor can be defined in the Actors section by adding actor actor name;

• A new class can be defined in the Classes section by adding class class name.

4.5 Applying the changes

To save the changes, click on the “Apply” button. If the user has entered a new
actor or class in the corresponding sections, the window 53 is shown to the user.
By clicking on “Yes”, the user will choose in which package to save the new item.

Figure 53: Save notification

For example, in Figure 54, the new actor CBL has been added to the actor
section.
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Figure 54: Creation of new actors and classes

If there are errors in the classes or actors section, the error message in Figure 55
is shown to the user. In that case, the user must correct the errors before applying
the changes.

Figure 55: Error notification.

If there are errors in the requirement description, the tool allows the user to
apply the changes but a warning message as in Figure 56 is shown.

Figure 56: Warning message if there are errors in the requirement description.

5 Trace Links Generation

Qualisist offers the user the ability to manage a trace relationship between an
element in Activity Diagrams and requirements. To use this feature, the MDG
“Core Extension” must be enabled. From the Top Bar Menu, select “Specialize”
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then in the “Technologies” section select “Manage”. Verify that the “Core Exten-
sion” is checked. To verify if an element has trace links to requirements, select
the element from the Activity Diagram or from the Project Browser, then click
on Start → Trace → Traceability. The box in Figure 57 will appear. For ex-
ample, in the figure, the selected element “Forward files” has a trace link to the
requirement “DDP020”.

Figure 57: Traceability box in Enterprise Architect.
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The tool can be opened in the following ways:

• Right-click on an element in the Activity Diagram and then select
Specialize→ Qualisist RE Tools→ Create new Trace Link

• Select an element in the Activity Diagram and then from the Top Bar Menu
select Specialize→ Qualisist RE Tools→ Create new Trace Link

• Double-click on an element in the Activity Diagram, then click “Yes” in the
dialog window shown in Figure 58.

Figure 58: Dialog box to open Qualisist RE Tools.

The form in Figure 59 will be opened.

Figure 59: Form to create a trace link.

The user has two options:

• Create a trace link between the selected element and a new requirement that
does not exist in the model. The tool asks in which package to save the new
requirement, as shown in Figure 60;
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• Create a trace link between the selected element and an existing requirement.
In this case, the tool shows the list of the requirement available in the model
as shown in Figure 60.

Figure 60: The form shows the list of the packages where to save the new functional
requirement and the list of functional requirements.

If a trace link is created between a requirement and an action, the “New - IT
impacts” stereotype is set to the action itself.

5.1 Generate and Update Trace Links between Actors and Re-
quirements

Given an action related to a requirement via trace link and belonging to an Activity
Partition, Qualisist provides the possibility to create or update a trace link between
the Activity Partition and the Requirement connected to the action.

To use this feature, select the Activity Diagram in the Project Browser
where the Action is placed then select: Specialize → Qualisist RE Tools →
Generate relationships between Actors and Requirements.

6 Functional Requirements Auto Naming

Whenever a functional requirement is created, the tool automatically generates
the new ID for that requirement.

6.1 Auto Naming Configuration

The user can configure the tool by setting the prefix, i.e. the letters that make
up the ID, and the increment value set by default to 5. From the Top Bar Menu
select Specialize → Qualisist RE Tools → Configure Qualisist Auto Naming.
The window in Figure 61 will be opened.
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Figure 61: Window to configure auto naming for the functional requirements in
Enterprise Architect.

Once finished with the changes, click on “Apply” to save them.

7 Acceptance Criteria Generation

Acceptance Criteria (AC) are conditions that a system must meet to be consistent
with its requirements and be accepted by its stakeholders. Qualisist provides an
automated solution to generate AC [Alf+19]. The Gherkin language is commonly
used to express AC using a Given-When-Then structure: Given [initial context]
When [event or action] Then [expected result] [WH17].

7.1 How to generate Acceptance Criteria

Select the Activity Diagram in the Project Browser, then you can generate AC in
two ways:

• From the top bar menu
Specialize→ Qualisist AC Generator → Calculate Acceptance Criteria

• Right-click on the selected Activity Diagram then from the drop-
down menu, select Specialize → Qualisist AC Generator →
Calculate Acceptance Criteria

Figure 62: How to run the acceptance criteria generator.

Next, the tool asks where to save the files that will be generated as shown in
Figure 63. Select a folder or create a new one.
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Figure 63: The tool asks the user where to save the new files.

By clicking on “Ok”, the tool will generate the files with extension .feature in
the chosen folder. To open these files, we recommend the Atom editor because it
keeps the colors and format of the Gherkin language as shown in Figure 64.

Figure 64: The acceptance criteria generated from a model.
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8 Model and Requirements Validation

Qualisist Model Validation is a tool to validate the elements in the model according
to the UML paradigm and methodology proposed by Clearstream.

8.1 How to configure Qualisist Model Validation

Qualisist Model Validation provides to the user four rules categories:

• Qualisist Rules Intra-Requirements: a set of rules to validate the properties
of a functional requirement (e.g. the ID of the functional requirement must
be unique in the model)

• Qualisist Rules Intra-Diagrams: a set of rules to validate elements in a dia-
gram

• Qualisist Rules Inter-Diagrams: a set of rules to validate elements in different
diagrams

• Qualisist Rules Inter Requirements and Diagrams: a set of rules to validate
the textual description of a functional requirement against the elements in
the model

You can enable or disable one or more category selecting the items in the form
shown in Figure 66. To open it click on Design → Edit → V alidation →
Configure V alidation Rules. Only the rules selected will be used by the tool
to validate the element.

Figure 65: Menu item to configure the validation rules or to run the tool
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Figure 66: Model Validation Configuration

8.2 How to run Qualisist Model Validation

You can validate an element in three ways:

• Select the element to validate, then click on Specialize →
Qualisist Model V alidation → V alidate Current Package (CTRL +
ALT + V )

• Select the element to validate, then press on the keyboard the following
combination CTRL+ALT+V

• Select the element to validate, then click on Design → Edit →
V alidation→ V alidate Current Package as shown in Figure 65.

When the validation process is running, the form in Figure 67 is shown. The user
can decide to end the execution by clicking on “Cancel Validation”.

Figure 67: The validation process is running

8.2.1 Output of the validation process

Once the execution is finished, the result is shown in the “System Output” box as
in Figure 68.
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Figure 68: Output of the validation process

If an element in the model does not comply with one of the rules defined in the
tool, Enterprise Architect displays a warning message to the user. The message
informs us which element in the model does not comply with the rules and a brief
description of the error.

References
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